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1. General Description

ACPWorkbench, the visualization tuning tool, is a real-time audio effect flow
plotting and tuning tool. Compared to version 2, this version has undergone
significant visual and functional changes. Whether you're a seasoned user of the
MVsilicon SDK or a newcomer, you'll benefit from its intuitive operation and rapid
customization of audio effect streams. Its main features include:

< Intuitive Interface: Presents the description of audio effect flow in a graphical
format, allowing users to visually see the effects and specific data flow on each
channel.

<> Real-time Preview: Users can dynamically zoom in to view the overall flowchart
as needed, or zoom in to examine specific details of individual audio effects.

<> Rapid Customization: Supports offline editing of audio effect flowcharts. For
DU series, after editing, it supports one-click download; for SDK series, after
editing, it supports one-click export of .c and .h files, which can be imported for
compilation and download via the SDK to showcase the effects.

< Real-time Tuning: Once connected successfully with the firmware,
ACPWorkbench allows real-time online adjustment of parameters for each audio
effect and immediate listening to the effects.

<> Sound Library Refresh: When connected to the firmware, ACPWorkbench
automatically updates to the current firmware's audio library. When disconnected
from the firmware, users can manually refresh it to the desired audio library
according to their needs, enabling audio effect flowchart editing.

< Automatic Parameter Saving: Supports automatic saving of audio effect flow
and parameters at regular intervals, with the option to disable this feature.

<> Parameter Import and Export: Supports manual import and export of audio
effect parameters and hardware parameters, making it easy to quickly present the
parameters adjusted by the user.
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2.

SRR R

<>
<>

Getting Started

ACPWorkbench contains the following files:

Example roboeffect libra  ACPWorkbench  ACPWorkbench Changelog Loglinfo
ry_info_set -CHS
Figure 1 ACPWorkbench files

ACPWorkbench.exe is the main executable.
ACPWorkbench-ENG.pdf is the help document in English.
ACPWorkbench-CHS.pdf is the help document in Chinese.
ChangelLog is the change logs file.

Roboeffect libraty info set folder contains binary files of different audio engine
libraries. By default, when ACPWorkbench boots up, it will search for the highest
version of the audio engine library binary file in this folder and then refresh the
offline library.

Loglnfo is an interactive log file.
Example contains examples of sound effect flows.

When ACPWorkbench is launched, it will automatically find and connect the

demo board via the connected UART (serial) or USB (HID) port. Once connected,
ACPWorkbench will read all the configurations in chip and update its GUI controls
accordingly. Please ensure the demo board is connected to PC and powered on.
Whenever the demo board is powered on/off, ACPWorkbench will always try to
re-connect it

<>

Offline Editing: When ACPWorkbench is not connected to the firmware, it is in
offline editing mode. The title displays "ACPWorkbench Disconnect — [Offline
Editing]", and the parameters in the status bar have no background color. When
ACPWorkbench is connected to the firmware and manual changes are made to
the audio effect flow, causing inconsistency between the interface's audio effect
flow and the firmware's audio effect flow, the firmware is online but in editing
mode. The title displays "ACPWorkbench for xxxxx — [Offline Editing]", and
the background color of the parameters in the status bar is yellow.

Online Tuning: When ACPWorkbench is connected to the firmware and the
audio effect flow is consistent with the firmware's, it is in online tuning mode.
The title displays "ACPWorkbench for xxxx—/[Online Tuning]", and the
background color of the parameters in the status bar is green.

Below are two different scenarios, each illustrating the online tuning state and the
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offline editing state:
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Figure 2 Online Editing
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Figure 3 Offline Editing
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3. Interface
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Figure 4 ACPWorkbench Ul

< Title Bar: Displaying the current firmware information.
<> Menu Bar: Includes File, Settings, Downloader and help menu options.

< Tool Bar: General operation tools for the flowchart area, including new, open
file, save, run, download, zoom in, zoom out, full image, export image, set
font color, set background color, customize the height and width of the
connecting line, and multiple sets of parameters for real-time comparison
operations;

< Flow Chart Area: Shows a flowchart of the firmware upload or a flowchart
drawn with a user-defined description;

< Tuning Section: Used to adjust sound parameters;

< Status Bar and System Control Area: In this area, if there is a firmware
online, it will display the current firmware's CPU consumption and other
information in real time. Meanwhile, hardware parameter configuration, reset,
refresh and debug assistant are also supported in the status bar;

4. Menu Bar

4.1 File

The file contains: New Audio Flow File, Import Audio Flow from, Export Audio
Flow to, Export Audio Parameters to, Refresh Offline Audio Effect Library and Exit;
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B AcPWorkbench
File Semings Downloader Help

Mew Audio Flow File I
w Import Audio Flow from...

%  Export Audio Flow to...
Export Audio Parameters to..
e Refresh Offline Audio Effect Library
@ Exit
Figure 5 File Menu

4.1.1 New Audio Flow File

Click File>New Audio Flow File to recreate a new audio flow file, if there is a
previous audio flow architecture file, a dialog box will pop up whether to save or not,
according to the needs of the choice to save or not to save.

4.1.2 Import Audio Flow from

Click File=> Import Audio Flow from... and the file path selection will pop up,
select the file to import the audio flow file. If the audio flow contains parameters,
refresh the parameters at the same time. If the file import fails, you can pay attention
to the following points:

<>
<>

Whether the imported file is a audio flow architecture file;

Whether the current ACPWorkbench audio effect library supports all the
audio effects in the imported file; if the audio effect library of the tuning tool
is of a lower version, refresh the offline library.

4.1.3 Export Audio Flow to

Click File=>Export Audio Flow to... and the export file screen will pop up:

1.

For the SDK that supports effect mode interaction protocol, as shown in the
figure below, it contains: file type, engine version, effect mode, parameter
group, and name of the exported file, in which the default effect modes are all
selected, which means that the exported file contains not only the content of
the audio flow, but also the parameters of the selected modes; if the user does
not want to put audio flow and effect mode parameters into one file, he can
cancel the selection status of all modes, so that the exported file contains only
the content of the audio flow, and the export of effect parameters needs to use
the "Export audio Parameters" function to export parameters of the
corresponding modes in turn. If you don't want to put the audio flow and
parameters into one file, you can uncheck all the modes, so the exported file
will only contain the sound stream, and the parameters of the corresponding
modes need to be exported through the "Export Audio Parameters" function;
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£ Karaoke HanMai DianYin WaWaYin

B /Project/ACPWWorkbench/ACPWearkbench V3.9.X/bin/user_effect flow_music

Figure 6 Export Flow Ul for casel

2. For SDKs that do not support audio effect mode interaction, this part only
supports the data export of audio flow, and the parameters need to be exported

through the "Export Audio Parameters Wizard" function with the following
interface:

darameters (*.ini, *.c, *.h)

S1ZR&E: roboeffect library info v2.15.0.bin

-/Project/ ACPWorkbench/ACPWorkbench W3 9.%/binjuser_effect flow_music

Figure 7 Export Flow UI for case2

3. Users can choose different export methods according to their needs.

< SCHERAL: Includes ini files, c/h files and exports all supported types at
the same time.;

< 5|ZERRA: Enumerates all engine library versions available to the user in
the roboeffect library info set folder of ACPWorkbench;

< B FR: Select the export file path and name;
4.1.4 Export Audio Parameters

Clicking File->Export Audio Parameters to... will bring up the selection of the
file path, this function supports the export of audio parameters in the current mode.
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%&%i&%ﬁ%ﬁfﬂé

Lt

E®:  Source Files for Current Parameters (*.c, *.h)
SIZERE: roboeffect library_info_v2.16.2.bin

SHER: @A

prg === <Ol P roject/ ACPWorkbench/ACPWorkbench_v3.9.X/bin/user_effect_param_music

Figure 8 Export Audio Parameters Ul
4.1.5 Refresh Offline Audio Effect Library

Click File>Refresh Offline Audio Effect Library, a file selection pops up, select
the audio effect library file (bin format) and click input to refresh the offline audio
effect library. effect libs_info x.x.x.x.bin file is synchronized with the release of the
engine library, please look for it in the engine library package. ACPWorkbench will
search for effect libs_info x.x.x.x.bin in the current path by default when it starts, if
it exists, it will refresh the parameters of the current bin.

4.1.6 Exit

Click the Exit button to exit the ACPWorkbench.exe program immediately!
4.2 Settings

The setup menu contains: Communication Type, Offline Chip Type, Sample Rate,
MCLK Source, Frame Size, Heartbeat Time, Tag Config and AutoSave Audio Script.

B ACPWorkbench
File | Settings Downloader Help

i Communication Type .. I

Offline Chip Type »
Sample Rate [ Global )} »
MCLK Source ( Global) P

Frame 3ize ...

Heartbeat Time ...

Tag Config...

~  AutoSave Audio Script

Figure 9 Settings
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4.2.1 Communication Type

Supports two communication modes: USB and UART.

B Communication Type Settings X

mvsilicon B1 usb audio

Figure 10 Communication Type

4.2.2 Offline Chip Type

If the device is in online mode, ACPWorkbench will automatically recognize the
chip type; if the device is in offline editing mode, the chip type can be selected as
needed so that the hardware can be switched to the corresponding series of
parameters.

B ACPWorkbench

File | Semtings Downloader Help

W

Offline Chip Type % APBZ2ux
Sample Rate [ Global ) » BP10xx
MCLK Source | Global) » BP1 5xx
Frame Size ...
Heartbeat Time ...
Tag Config...

'  AutoSave Audio Script

Figure 11 Offline Chip Type

4.2.3 Sample Rate

Inactive and 13 sample rates (8000-192000Hz) are included. When 13 sample
rates are selected, the global sample rate is enabled and all hardware modules are
configured according to the current sample rate; when Inactive is selected, the global
sample rate is not enabled and each hardware module is configured according to the
local sample rate parameters.

The sample rate of the audio effect module comes from the sample rate in the
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chart information;

4.2.4 MCIKk Source

Inactive and 5 MCLK source selections are included. Select 5 MCLK sources:
PLL Clockl, PLL Clock2, OSC IN, MCLK INO, MCLK IN1, and global MCLK
Inactive; when selecting the 5 sources, the local MCLK source does not work; when
selecting Inactive, the global MCLK source does not work, and each module is
configured according to the local MCLK source.

4.2.5 Frame Size

Click Settings—>Frame Size... The following window will pop up, select the
desired frame size and click Apply to download it to the firmware;

B Frame Size Setting *

Frame Size B sampiles

Figure 12 Frame Size

4.2.6 HeartBeat Time

Click Settings—>HeartBeat Time... will pop up the following window, enable or
disable the heartbeat packet function according to your need, and if enabled, it also
supports the heartbeat packet interval time setting.

If heartbeat packet is enabled, ACPWorkbench will read all the status information
of the firmware according to the set interval.

B | HeartBeat Time >

HeartBeat Enable 1000 ms

Figure 13 HeartBeat Time

4.2.7 Tag Config

Communication protocol OxFC provides a custom label function, the user can use
the function according to the actual needs; support for character and HEX two editing
formats, as follows
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8 Tag Information X

IEH K3 KN KN K3 K1 KN KN 3 BN B R .

4 SET

Figure 14 Tag Config
4.2.8 AutoSave Audio Script

The default checkbox of the tuning tool is AutoSave, which will save the audio
parameters and audio flow files on a regular basis; if the user cancels this function,
just remove the checkbox.

ACPWorkbench for BPxx KARACOKE
2 | Settings | Downloader Help
I Communication Type ..

Sample Rate | Global ) #
MCLK Source | Global) #

\PF
Frame Size ...

Heartbeat Time ...

Tag Config...

» AutoSawve Audio Script

Figure 15 AutoSave Audio Script

4.3 Downloader

The download menu contains the firmware upgrade and save parameters to flash
functions;

B ACcPWorkbench for BPwx KARAOKE SDK, version -
File Settings | Downloader Help

Firmware Upgrade...

Sawve Configurations to Flash...

Figure 16 Downloader
4.3.1 Firmware Upgrade
ACPWorkbench.exe supports online firmware upgrading, by clicking the

"Downloader" menu, the "Firmware Upgrader" window will pop up. Then select the
downloaded mva file and click the download button to upgrade it. And the upgrade
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process is displayed in the status bar of the upgrade window in real time.

Currently, firmware upgrade only supports USB communication. There are two
kinds of upgrade methods: application layer upgrade and BOOT upgrade (check
Firmware is in boot).

B Firmware Upgrader et
Pa

Figure 17 Firmware Upgrade

4.3.2 Save Configurations to Flash

The download menu supports saving parameters to flash online. After saving the
parameters, the firmware will read the parameters from the flash when powering up
next time. Supports various commands to save flash parameters for compatibility with
various chip types.

4.4 Help

Content-Chinese: Click this menu to open the Chinese help file of
ACPWorkbench.exe.

Content-English: Click this menu to open the English help file of
ACPWorkbench.exe.

Key: When the firmware or SDK is encrypted, you can enter the key to get the audio
parameters by clicking on this menu.

About: Clicking on this menu displays information about the software.
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5. Audio Effect Flow Chat Area

5.1 Tool Bar

In the toolbar from left to right are New, Open, Save, Compile, Download,
Settings, Zoom In, Zoom Out, Global Spread, Export Image, Font Color Settings,
Background Color Settings, Horizontal Spacing of Sound Modules, Vertical Spacing
of Sound Modules, effect Modes, and A/B Comparison for each group of effect modes.
As shown in the picture below:

¢ x@v Parameter Group :

SR RS

Figure 18 Tool Bar
New: Create a new diagram;
Open: Open file;
Save: Saves the current sound stream file;
Compile: Compile the current audio flow graph;

Download: When ACPWorkbench is connected to the DU firmware, this
button is enabled, i.e., it allows the drawing to be downloaded to the
firmware with a single click after it is finished; when connected to the SDK,
this button is disabled, and the finished drawing is exported to the SDK with
all the information of the drawing through the button Export Sound
Parameters in the File menu;

Settings: Some system configurations;

Zoom In / Out: Clicking on the buttons will zoom in and out of the
flowchart.

Global Spread: Clicking this button causes the tuning tool to display the
graphic spread globally at the current tool size;

Export Image: Clicking on it will automatically take a screenshot of the
image in the current flowchart area and save it to a path of the user's choice;

Font Color Settings: Support for changing font colors in flowcharts;

Background Color Settings: Support flowchart background color changes,
such as the following figure were selected standard white, Dark dark for the
effect of the demonstration;

Parameter Group: Effect Mode, compared with 3.8.X and previous versions,
3.9.0 has added the effect mode function. Each effect mode also supports

A/B comparison; when creating or modifying a effect mode, click the button
Hon the right to customize the effect mode according to your needs.
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5.2 Editing Flowcharts

Flowchart area can be realized to draw flowcharts and control flowcharts, as
shown in the following figure. In the flowchart area you can use the mouse to
complete some operations.

e ——pin—— R TEE BB e —B e b o — mzp —> e — SR = —* o

SERR L LT

o e - - -

L g

e e e
uts,runad

Figure 19 Editing Flowcharts

5.2.1 New Source

Right-click on any position in the flowchart area to bring up a pop-up menu,
select "Hr 4 Source %1 A" to bring up the "#7 % source Ji " window, enter the name,
select the bit width and the number of channels.

W ACPWorkbench for BPT5 KARAUKE SUK, Version = 0.3, EffectLl = 2310, Koboeffectllt = 2./.6- |&5E5mE]

File Semings Downloader Help

[ #ESourceBA
UndofEfE
#  Redoiiéfte

BiraE —

source0

Figure 20 New Source

5.2.2 New Effect

If you want to add a audio effect after a audio effect, you can right-click on the
module, in the pop-up menu, select "HT &&= 4T J5", and then it will pop up all the
current support for the audio effect, select the audio effect will be automatically
compiled, if the compilation is successful, it will be automatically added to the chart.
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ACPWorkbench for DUS61, Version = 0.0.0, EffectLIE auto_tune upmix_Tto2

: Settings Downloader Help auto_wah user_gain
ﬁ beamforming virtual bass.
beat tracker virtual bass_classic
biquad virtual bass td
channel combiner vocal cut
channel_selector vocal remover
chorus voice_changer
chorus2 woice_changer_pro
compander
de blocker
soutee e distortion_ds1 \
ErEreTE O / downmix 2to1 »
siF dre I )
EEL Eﬁ\ o FEESTRE cho
B Y = e engine_sound
= o
B === eq_dre
0 $ESourceA fader
 UndoifE flanger
Redof2fE freq_shifter
o EEr freq_shifter_fine
gain_control

harmonic_ exciter

Figure 21 New Effect
5.2.3 Connecting Existing Effect

Multiple input source audio effects (e.g. AEC) or Node nodes allow multiple

inputs, if the audio effect has already been drawn on the graph and other audio effects

want to connect to it, you can select "Iz TV & 21", as shown in the following

[T r——

wicsouce b+ vamers |_'i_"’ M souRCE -bi " o —p P
\; s

Figure 22 Connecting Existing Effect

5.2.4 Delete Effect

1. For normal audio effects, right-click on the module to be deleted, and then select "
IR 24 & 20" to delete it, as shown in the following figure.
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@ ACPWorkbench for DUSE1, Version = 0.0.0, EffectliB = 2.34.1, RobosffectllB = 27,12 [HEERE)
File Semngs Downloader Heip

W ACPWarkbench for DUSG1, Version = 0.0.0, EffectliB = 2.3
File Semings Downloader Help

Mvsilico

Figure 23 Delete Effect
2. If'you want to delete a node effect that has multiple branches, you need to reduce
the branch to a single branch before you can delete the node effect.
5.2.5 Disconnect Effect

If the current effect is followed by a multi-input effect, and disconnecting the
current connection will not affect the normal flow of the subsequent effects, then this
effect can be disconnected from the subsequent effects, as shown in the following
figure.
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© mEseEn
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Figure 24 Disconnect Effect
5.2.6 Move Effect

Normal effects allow forward and backward operations between them, as shown
below:
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Figure 25 Move Effect
5.2.7 Rename Effect

Select the effects that need to be renamed, right mouse button, in the pop-up
menu, select "L A7 4", and then modified in accordance with the requirements can be,
as shown in the figure below.

B ACPWorkbereh for BP1S KARMOKE SDK, Nersicn = 023, Efiecti = 2320, RsborkectU8 = 2711- [RSRl) - o x|

Figure 26 Rename Effect

5.2.8 Undo/Redo

Supports undo/redo operations within 5 operations.

5.2.9 Configuring Read-only

If you want to design a flowchart in which some specific modules are not allowed
to be deleted or renamed, you can lock them by setting them to read-only, as shown in
the following figure, there will be a lock flag in the "mic_gain" module, so that the
The "mic gain" module will have a lock symbol, so that the mic_gain sound effect
will be set to read-only, and the user will not be able to delete or rename it.
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Figure 27 Configuring Read-only
5.2.10 Sequential Operation of Multi-input Effects

General multi-input effects on the input order has certain requirements, if the
design flow chart and the demand for the order of the difference, you can right mouse
button, in the pop-up menu, select "t B Hi AVRNITT", in the pop-up window, select
the order of the need to complete the switch.

18 = 2711 (W)
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Q woEmEN
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sE=many mic
4 FRERTE
we b a i =

# wsmss
B Eaz

- EEEARES
) ElSourceih,
* UndoiRf®

R ERsmEE

Figure 28 Sequential Operation of Multi-input Effects

5.3 Control Flow Chart

5.3.1 Drag

Drag the mouse anywhere in the flowchart area and the drawing will move with
the mouse;

5.3.2 Zoom In / Out

After left-clicking anywhere in the process, scrolling the mouse wheel will
enlarge the diagram display, and scrolling the mouse wheel in the opposite direction
will reduce the diagram display;
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5.3.3 Enable / Disable Current Effect

In the position of the effect module, right-click the mouse, the following menu
will pop up, click "8 2 HI & 2L", it will notify the firmware to turn on the current
effect, click "% 24 H % 4L", the tuning tool will notify the firmware to turn off the
current sound. If you right click on a non-effect module to bring up the menu, "Turn
on current effect" and "Turn off current effect" are disabled;

0x86 16,1
ﬁ =  nhase cont
0 FE=EEH rolo
Q F=AZgEN
V=i
q gain (1) FARRESEN
C e mmmaEn
PEFFREEN

0296 24,1
_. _. freq_shift _’ howling_su
erd ppressorQ

Qo

Figure 29 Enable / Disable Current Effect

5.3.4 Enable / Disable All Effects

Unlike turning on/off the current effect, turning on/off the display of all effect
functions does not require selecting a location, just right mouse click anywhere in the
flowchart area as shown below. Clicking on it will notify the firmware to turn on or
off all effect modules;
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Figure 30 Enable / Disable All Effects
5.3.5 Refresh Current Effect

Right click on the effect module that needs to be refreshed, a pop-up menu will
appear, select "l HT 2 51 & 44" and the tuning tool will immediately read all the
parameters of the current effect module;

5.3.6 Refresh All Effect

Right click anywhere in the flowchart area (not limited to the sound module) to
bring up the menu and select "Will# T % XL", the tuning tool will immediately read
all the effect parameters in the current chart;
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6. Online Tuning

6.1 Select Effect

If you left-click on the effect module in the flowchart area, all the parameters of
the selected effect will be displayed in the online tuning area. As shown in the figure
below, eq0 in the flowchart is selected by left clicking on the mouse, and then all the
parameter information of eq0 is automatically switched to the tuning area, and each
parameter can be adjusted at this time.

B ACPWorkbench for B9 KARAOKE SDK. version = 040, affectlis = 2.26.0 - (4
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Figure 31 Select Effect
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7. System Control

There are several system controls on the status bar: Hardware Config, Reset,
System, and Port Assistant.

Figure 32 System Control
7.1 Hardware Config
Click the Hardware Config button on the status bar, the hardware parameter

interface of the corresponding model will pop up, as shown in the figure below, and
you can adjust the corresponding parameters according to your needs:

PGAL
[June2z ¢ L R) [June2 ¢ 'L R} [Lined ¢ 'L R) CImc2 []mict

e [ e (LS

MClk Source | 11«1

... won JEETE o BEEEE DR ~~EEDE
P R — | P~
e [N om0 s rones [N

Figure 33 Hardware Config

7.2 Reset

After clicking the "Reset" button on the status bar, the reset options will pop up:
system reset or factory reset.

< System Reset: It just resets the firmware successfully without changing the
parameters;

< Factory Reset: While resetting the firmware, the parameters are restored to
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the factory parameters;

7.3 Refresh

By clicking "Refresh" on the status bar, the tuning tool will re-read all the
parameters of the device.

7.4 Port Assitant

After clicking "Port Assitant" on the status bar, the window of debugging
assistant will pop up, you can manually send commands or read certain commands, as
shown in the following figure:

& Smart Port Assistant X

[2023.08.24 13:10:15.747 J 8] [UART TX] - Firmware Info: Control Word =0x00, Data Length = 0x00
A5 SA 00 00 15

a5 5a 0000 16 ~ B s

Figure 34 Port Assitant
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8. Log Information

The ACPWorkbench provides a log information file, the storage path is the path
where the ACPWorkbench is located, the name is "LogInfo.txt". It stores all the
interaction information between the ACPWorkbench and the firmware, which is
convenient for locating the problem in the development stage, as shown in the figure
below, including time, direction and content, in which HID-TX means that the
ACPWorkbench sends to the firmware, and HID-RX means that the firmware uploads
to the ACPWorkbench:

1 2023-08-24 13:15:18.793 [HID-TX]: 0xaS5, 0x5a, OxFF, 0x00, 0x16

2 2023-08-24 13:15:18.797 [HID-RX]: OxA5, Ox5A, OxFF, 0x03, 0x00, 0x00, 0x00, 0xl1€

3 2023-08-24 13:15:18.821 [HID-TX]: OxA5, OxS5A, 0x00, 0x00, O0x1€

4 2023-08-24 13:15:18.826 [HID-RX]: OxAS, O0x5A, 0x00, O0xOA, O0x31, O0x00, O0x04, 0x00, 0x02, Oxla, 0x00, O0x02, O0x05, 0x00, O0x16

S 2023-08-24 13:15:18.832 [HID-TX]: OxAS, 0x5a, 0x01, 0x00, 0x16

2023-08-24 13:15:16.838 [HID-RX]: OxA5, 0x5a, 0x01, O0x0F, OxFF, 0x00, 0x00, 0x00, 0x00, 0x00, O0x01, O0x07, 0x00, 0x01, O0x00, 0x0
2023-08-24 13:15:18.844 [HID-TX]: OxA5, 0x5a, 0x03, 0x00, O0xl€

8 2023-08-24 13:15:18.849 [HID-RX]: OxAS, OxS5A, 0x03, Ox2F, OxFF, O0x01, 0x00, 0x0l, O0x00, 0x00, O0x00, Ox00, O0x00, 0x00, 0x00, 0x0
S 2023-08-24 13:15:18.855 [HID-TX]: OxAS, 0x5h, 0x04, 0x00, Ox1€

10 2023-08-24 13:15:18.861 [HID-RX]: OxAS, O0xS5A, 0x04, 0x15, OxFF, O0x03, 0x00, 0x00, 0x00, 0x00, 0x10, O0x00, 0x10, 0x07, 0x00, 0x0
11 2023-08-24 13:15:18.863 [HID-TX]: 0xaS, 0x5a, 0x06, 0x00, O0xl6

12 2023-08-24 13:15:18.867 [HID-RX]: OxAS5, O0x5a, 0x06, 0x13, OxFF, 0x01, 0x00, 0x01, 0x00, 0x0D, 0x00, 0x00, 0x00, 0x0D, 0x00, O0x0
13 2023-08-24 13:15:18.873 [HID-TX]: OxAS5, O0x5A, 0x07, 0x00, Ox1€

14 2023-08-24 13:15:18.878 [HID-RX]: OxAS, O0x5A, 0x07, 0x15, OxFF, O0x03, O0x00, 0x00, 0x00, 0x00, 0x10, Ox00, O0x10, 0x07, 0x00, 0x0
15 2023-08-24 13:15:18.884 [HID-TX]: OxAS, 0x5h, 0x08, 0x00, 0x16

16 2023-08-24 13:15:18.850 [HID-RX]: OxAS, O0x5a, 0x08, OxID, OxFF, O0x00, O0x00, 0x00, O0x00, 0x00, 0x00, Ox00, O0x00, 0x00, 0x00, 0x0
17 2023-08-24 13:15:18.896 [HID-TX]: 0xaS, 0x5a, 0x09, 0x00, O0x16

18  2023-08-24 13:15:18.859 [HID-RX]: OxAS5, 0x5A, 0x09, O0xID, OxFF, 0x03, 0x00, 0x07, 0x00, 0x00, 0x00, Ox00, O0x10, 0x00, O0x10, 0x0
S 2023-08-24 13:15:18.903 [HID-TX]: OxAS5, O0x5A, O0x0A, 0x00, Oxl€

2023-08-24 13:15:18.907 [HID-RX]: OxA5, OxS5A, OxOA, Ox1D, OxFF, O0x0l, 0x00, 0x07, 0x00, 0x00, O0x00, O0x00, O0x10, 0x00, O0x10, 0x0
2023-08-24 13:15:18.912 [HID-TX]: OxA5, Ox5A, 0x0B, 0x00, O0x16

2023-08-24 13:15:16.918 [HID-RX]: OxA5, 0x5a, 0x0B, 0x17, OxFF, 0x00, 0x00, 0x00, 0x00, 0x49, OxFF, 0x00, 0x00, 0x48, 0x00, 0x0
2023-08-24 13:15:18.925 [HID-TX]: OxA5, 0x5a, 0x0C, 0x00, O0xl€

2023-08-24 13:15:18.931 [HID-RX]: OxA5, Ox5A, O0x0C, O0x17, OxFF, O0x00, 0x00, 0x00, 0x00, 0x49, OxFF, 0x00, O0x00, 0x48, 0x00, 0x0
2023-08-24 13:15:18.933 [HID-TX]: OxA5, Ox5A, OxFC, 0x00, O0x16

2023-08-24 13:15:18.937 [HID-RX]: OxA5, OxS5A, OxFC, 0x00, O0x16

2023-08-24 13:15:18.944 [HID-TX]: OxA5, 0x5a, 0x80, O0x01, 0x00, Ox16

2023-08-24 13:15:18.948 [HID-RX]: OxA5, 0x5a, 0x80, O0xF7, O0x00, OxFF, 0x00, 0x00, O0xll, 0x22, 0x02, OxlaA, 0x00, 0x36, Oxl4, 0x0
2023-08-24 13:15:18.954 [HID-TX]: OxA5, Ox5A, 0x80, O0x01, 0x00, O0xl6

2023-08-24 13:15:18.960 [HID-RX]: OxA5, Ox5A, 0x80, OxF2, O0x01, O0x72, Ox6€l, 0x63, 0x79, O0x3B, O0x6€2, O0x€5, O0x74, O0x74, O0x65, O0x7
2023-08-24 13:15:18.963 [HID-TX]: OxA5, O0x5A, 0x80, O0x01, 0x00, O0x16

2023-08-24 13:15:18.966 [HID-RX]: OxA5, 0x5a, 0xB0, OxF2, 0x02, O0x00, 0x€4, 0x00, 0x01, 0x00, O0x07, 0x72, O0x6€l, 0x74, O0x69, 0x6
2023-08-24 13:15:16.974 [HID-TX]: OxA5, 0x5a, 0x80, 0x01, 0x00, O0x16

2023-08-24 13:15:18.977 [HID-RX]: OxA5, Ox5A, 0x80, OxF2, 0x03, O0x74, O0x€5, OxEE, 0x75, Ox6l, O0x74, O0x€9, Ox6F, OxEE, 0x02, 0x7
2023-08-24 13:15:18.983 [HID-TX]: OxA5, Ox5A, 0x80, O0x01, 0x00, O0x16

2023-08-24 13:15:18.985 [HID-RX]: OxA5, OxS5A, 0x80, OxF2, O0x04, O0x65, 0x72, 0x31, OxS5F, O0x65, Ox6E, O0x6l, 0x6€2, 0x6C, 0x65, 0x0
2023-08-24 13:15:18.995 [HID-TX]: OxA5, O0x5A, 0x80, O0x01, 0x00, 0x16

2023-08-24 13:15:19.000 [HID-RX]: OxA5, 0x5a, 0x80, O0xF2, O0x05, O0x69, O0x6C, O0x74, O0x65, 0x72, 0x33, O0x5F, O0x6€7, 0x6l, O0x69, O0x6
2023-08-24 13:15:19.003 [HID-TX]: OxA5, 0x5A, 0x80, 0x01, 0x00, O0xl6

2023-08-24 13:15:19.006 [HID-RX]: OxA5, Ox5A, 0x80, OxF2, O0x06, O0xC8, 0x00, 0x00, 0x00, 0x09, O0x66, O0x€9, O0x6C, O0x74, O0x65, Ox7
2023-08-24 13:15:19.012 [HID-TX]: OxA5, Ox5A, 0x80, O0x01, 0x00, O0x16

2023-08-24 13:15:19.015 [HID-RX1: OxA5. OxS5A. 0x80. OxF2. O0x07. O0x74. O0x79. O0x70. O0x65. O0x00. O0x00. O0x00. 0x00. 0x00. OxOA. 0x6

Figure 35 Log File
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9. CPU AND MEMORY USAGE

ACPWorkbench can read and display the CPU and memory usage of the chip in
real time after it has connected to the demo board successfully.

9.1 CPU Usage

ACPWorkbench displays CPU usage in real time on the bottom progress bar. The
unit MCPS means mega cycles per second. When CPU usage exceeds that maximum
limit, the process bar’s color will turn red to give a warning. In this case, the chip is
not able to work in real time, and certain delays can be heard in output as a result.

9.2 Memory Usage

Memory usage will be displayed in digital form.
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10. CONTACT INFORMATION

Shanghai Head Office

Address: Suite4C, Hengyue International Building 3, 1238 Zhangjiang Road,

Shanghai, P.R. China
Zipcode: 201203
Tel: 86-21-68549851/68549853/68549857
Fax: 86-21-58992765

Shenzhen Sales & Technical Support Office

Address: Suite6A, Olympic Plaza, Shangbao Road, Futian District,
Guangdong, P.R. China

Zipcode: 518034

Tel: 86-755-83522955

Fax: 86-755-83522957

Email:  support@mvsilicon.com

Website:  http://www.mvsilicon.com

Shenzhen,
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